검색
검색
공개 노트 검색
회원가입로그인

amazon linux 2에서 node 18 버전 지원 안함.

amazon linux 2에서 node 18 버전 지원을 안하네요. 현재 18이 LTS 버전인데...

node: /lib64/libm.so.6: version `GLIBC_2.27' not found (required by node)

이런 에러가 나서 찾아봤더니 Amazon Linux 2 에서는 Glib 2.26 이하만 지원한다고 합니다.

lightsail의 경우 Ubuntu 외에는 Amazon linux 2일텐데 약간 의외네요.

node 16 버전을 쓰다가 나중에 변경했습니다.

결국 다음 링크의 답변을 활용해서 node 18.17.1 버전을 설치했습니다.

Node.js 18 on Amazon Linux 2

amazon 팀에서 쓰려고 특정 버전을 만들어 둔 것입니다.

조회수 : 1268
heart
공유하기
카카오로 공유하기
페이스북 공유하기
트위터로 공유하기
url 복사하기
T
페이지 기반 대답
AI Chat